Suche

Freitag, 11. Januar 2013

Nutzung der Mehrsprachigkeit in SharePoint 2013

Heute wollte ich mich mit dem Thema <Mehrsprachigkeit und SharePoint 2013> auseinandersetzen. Wie in SharePoint 2010 bietet Microsoft auch diverse Sprachpakete für SharePoint 2013 an. Zum heutigen Zeitpunkt stehen Sie leider noch nicht zum freien Download bereit. Wenn Ihr jedoch eine MSDN-Subscription besitzt, so könnt Ihr die verfügbaren Sprachpakete hier herunterladen. Die folgenden Sprachpakete stehen derzeit zum Download bereit.




















Nachdem ich mir die Pakete installiert und den Config-Wizard laufen gelassen habe (Es hat keine 10 Minuten gedauert, das sieht mir nach Optimierung aus) stehen die Pakete zur Verfügung und ich kann Sie auf den einzelnen Site-Collections aktivieren. Dazu gehe ich wie gewohnt in die <Site-Settings>








und wähle dort die <Language settings> aus und markiere die gewünschte Sprache.


























Das sind alles keine Änderungen gegenüber SharePoint 2010. Meine Seite öffnet sich nun wie erwartet in Deutsch. Nun möchte ich jedoch wieder in die englische Sprache wechseln. Ist doch ganz einfach denke ich mir, so bin ich es aus SharePoint 2010 gewohnt über meine Einstellungen













die Sprache zu wechseln, diese Auswahlmöglichkeit fehlt in SharePoint 2013.



Ich habe mich dann auf die Suche nach den Einstellungsmöglichkeiten gemacht und bin leider nicht fündig geworden. Die Suche im Netz und Diskussionen mit den Kollegen ergaben dann die folgende Lösung oder soll ich es besser als Workaround bezeichnen, da es für mich persönlich nichts mit Usability zutun hat. Aber es funktioniert ;-)

Zunächst wechsel ich in mein Profil <Über mich>. Nicht wundern, dass nun auf einmal wieder englische Einstellungen zu sehen sind, aber die MySite wurde in englisch angelegt.











Um Änderungen tätigen zu können muss ich mein Profil bearbeiten <editing your profile>.













Wenn ich nun auf die berühmten <...> (diese sind in SharePoint 2013 häufig anzufinden) gehe, erweitert sich das Menü wie folgt und ich wähle den Punkt <Language and Region> aus. Solltet Ihr nicht in die <Language and Region> gelangen (eventuell aufgrund einer nichtvorhandenen MySite) könnt Ihr es auch direkt über diesen Link <http://servername/_layouts/15/regionalsetng.aspx?type=user&Source=http://servername/> versuchen.










Wie man erkennt sind in dem Bereich <My Display Languages> derzeit keine Einträge vorhanden.

















Ich füge nun die deutsche und englische Sprache hinzu.












Meine Seite wird immer noch in Deutsch angezeigt und auch in meinem Benutzermenü finde ich keinen Punkt um die Anzeigesprache zu wechseln. Also wechsel ich wieder zurück in meine Einstellungen und tausche die Reihenfolge der ausgewählten Sprachen.












Jetzt wird meine Seite auch in Englisch angezeigt :-).















Ich persönlich finde es umständlich und bin mir sicher, dass es den Anwendern wenig Freude bereiten wird. Es spricht generell nichts dagegen auf die Einstellungen aus dem System zuzugreifen. Jedoch bin ich der Meinung, dass man das Auswählen der Sprachen auch weiterhin über das Benutzermenü zulassen sollte.

Viele Grüße,
Patrick

Donnerstag, 10. Januar 2013

Aktivierung Blob Cache (Enable Blob Cache SharePoint 2013)

Heute wollte ich mich mit der neuen Funktionalität der <Image Renditions> (Bildwiedergabe) im SharePoint Server 2013 beschäftigen. Man kann den Punkt <Image Renditions> in den Site-Settings finden. Bevor ich nun jedoch Einstellungen und die Funktionalität nutzen kann erwartete mich zunächst eine Warnmeldung:

"The blob cache is not enabled in this web application. Image Renditions will not be generated until the blob cache is enabled. For information on turning on the blob cache, please review the product information."







Ich habe mich dann einmal in der Zentraladministration auf die Suche nach Einstellungen auf Webanwendungsebene für die Aktivierung des Blob Cache gemacht, bin in der GUI jedoch nicht fündig geworden. Was nun tun? Gibt es eventuell PowerShell cmdlets für SharePoint 2013 zum Aktivieren des Blob Cache. Auch hier bin ich leider nicht fündig geworden. Aber da es sich um Konfigurationseinstellungen der Webanwendung handelt so findet man diese doch bestimmt in der web.config. Einmal die Suche nach <BlobCache> gestartet und schon wird mir der folgende Punkt angezeigt:


Im nächsten Schritt setze ich <enabled> auf <true>.







Damit die Änderungen wirksam werden muss noch mit dem folgenden Befehl iisreset /restart /noforce in der Kommandozeile ein IIS-Reset ausgeführt werden. Nach einer Aktualisierung der Seite und etwas Wartezeit durch den IIS-Reset erwartet mich nun die folgende Ansicht und ich kann die <Image Renditions> in SharePoint 2013 nutzen.

















Wer mehr über Image Renditions in Erfahrung bringen möchte, dem kann ich die folgenden Artikel empfehlen:



Auch wenn dies nur ein kurzer Auftritt von mir war, so hoffe ich trotzdem, dass der Beitrag Einigen helfen wird den Blob Cache zu aktivieren.

Viele Grüße,
Patrick

Dienstag, 8. Januar 2013

Happy New Year 2013

Ich wünsche Euch ein frohes, gesundes und erfolgreiches neues Jahr 2013. Lassen wir dieses Jahr die Zahl für sich sprechen :-)


und hoffen auf viele erfolgreiche SharePoint 2013 Projekte. Zudem werde ich versuchen mich dieses Jahr intensiver um meinen Blog zu kümmern und meine Erfahrungen mit Euch zu teilen. Das nenne ich doch mal gute Vorsätze ;-)

Viele Grüße,
Patrick